To grab the latest freespace2 SVN (SVN view LINK):
svn co svn://svn.icculus.org/freespace2/trunk freespace2


Keep in mind, FreeSpace2 currently requires OpenAL, and SDL.